User login

You are here

An Ansible / Digital Ocean catch

If you get this error when running your new Ansible scripts, the problem may be that you're not running the right HEAD/2.0 digitalocean API from Ansible

ValueError: invalid literal for int() with base 10: 'xxx'

In any case, still have to love a project that names its releases after Van Halen tracks!

$ pip install ansible
Downloading/unpacking ansible
Downloading ansible-1.9.1.tar.gz (917kB): 917kB downloaded...

$ git clone git://github.com/ansible/ansible.git --recursive && cd ansible && source ./hacking/env-setup

$ cp ./v2/ansible/modules/core/cloud/digital_ocean/digital_ocean.py /usr/local/lib/python2.7/dist-packages/ansible/modules/core/cloud/digital_ocean/digital_ocean.py

Topic: